We’re saying goodbye to Internet Explorer 7 and 8

Internet Explorer logoAs of the end of December 2014, BidContender will no longer support Internet Explorer (IE) versions 7 or 8. This will affect any users accessing BidContender on these browser versions.

Will I still be able to use BidContender in IE7 or 8?

Yes, you will still be able to log in and work with BidContender using these versions of IE. However, we will stop testing on these browsers, which means that BidContender may occasionally look or perform differently, and some new functionality will not be available.

Why should I upgrade?

  • Security: Older browsers are more likely to have security problems that aren’t addressed by their manufacturers.
  • Speed: Using a newer browser can make your experience of the web faster and smoother.
  • Fewer bugs: By focusing on support for current browsers, we can respond more quickly to iron out bugs and issues.
  • Get more out of BidContender: Like most websites and apps, BidContender uses the latest technologies to bring you the most advanced functionality we can. These technologies require current browsers in order to work reliably. Without them, you may not be able to use the BidContender features you need.

How can I upgrade?

If your company has an IT department, we recommend you speak to them about upgrading your browser. If you have access to upgrade your browser, please download the latest version from the Microsoft website.

Can I use a different browser?

Of course you can. We highly recommend our users switch to Google Chrome where possible, as our testing has shown that BidContender runs significantly faster in most tasks when using this browser. Please download the latest version from the Google Chrome website.

What browsers do you support?

We provide full support for IE11, IE10, IE9, Firefox 11 or later, Chrome 25 or later.



Leave a Reply

Your email address will not be published. Required fields are marked *

*